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After external account is deleted and recreated, few or no alerts are generated

Problem

A recently recreated external account does not generate any alerts (or few alerts)

Symptoms

After deleting and recreating an external account, the reports generated contain significantly less alerts than before it was deleted.

Cause

When an account is deleted, the relevant alerts are removed from ESP Web, but they still persist in the backend.  If the account is recreated before the alerts expire in the backend, they will persist but not be pushed to ESP Web.

Resolution

Possible solutions:

  • Delete the external account, wait 3 hours, then recreate the external account.
  • Delete the external account, rename the evident service role to something else, and recreate the external account.  ESP backend caches alerts based on role ARN.  When the evident service role is renamed, the ARN will change, which will essentially clear the cache.
  • 75
  • 12-Dec-2017
  • 47 Views